4 de enero de 2015

Traducción de direcciones IPv6 a IPv4

La comunicación entre nodos conectados a redes IPv6 con nodos conectados a redes IPv4 es posible implementando un proceso de traducción mejor conocido como AFT (Address Family Translation).
Esta es considerada una estrategia de corto plazo pero que permite la coexistencia de ambas redes para facilitar una transición hacia la red IPv6. Aplicaciones que utilizan protocolos que incluyen información IP en la porción de datos (como FTP o SIP) requieren la implementación de gateways de capa de aplicación para soportar la traducción.
Hay 2 tecnologías disponibles para realizar estas traducciones:
  • NAT-PT
    Network Address Translation – Protocol Translation
  • NAT64
    Network Address Translation IPv6 to IPv4
El uso de NAT-PT no es recomendado por la IETF merced a su débil interacción con DNS y sus limitaciones para la traducción. Estos problemas están documentados en el RFC 4966.
La sugerencia es trabajar con NAT 64.

La traducción de IPv6 a IPv4 o viceversa es mucho más compleja que el NAT de IPv4 que todos conocemos ya que requiere la conversión de 3 elementos en cada paquete:
  • El encabezado IPv6 debe ser reemplazado por un encabezado IPv4 o a la inversa.
  • La dirección IPv6 de origen debe ser traducida a una dirección IPv4 de origen o a la inversa.
  • La dirección IPv6 de destino debe ser traducida a una dirección IPv4 de destino o a la inversa.
Cuando la sesión se inicia desde un host IPv6, el destino será un nodo IPv4, para representar la dirección de destino IPv4 en formato IPv6 se genera un ID compuesto por el prefijo 64:FF9B::/96 que se completa con los 32 bits de la dirección IPv4 de destino.
Del mismo modo, cuando la sesión se inicia en un host IPv4, la dirección IPv4 de origen será traducida por una dirección IPv6 compuesta por el prefijo 64::BB9F::/96 y los 32 bits de la dirección IPv4 del host.
Para la traducción de las direcciones de host IPv6 se utiliza un rango de direcciones IPv4 destinado por el Administrador para este propósito.
Veamos algunos elementos de NAT64.

NAT  64
Es una solución apta tanto para entornos corporativos como de service provider.
  • Implementa funciones de NAT64 a la vez que DNS64, lo que es la base de su superioridad respecto de NAT-PT.
  • Soporta múltiples y muy variados escenarios de traducción.
  • Se puede implementar en 2 maneras:
    - Stateless NAT64.
    - Stateful NAT64.
Stateless NAT64
  • Definido en el RFC 6145.
  • No realiza ningún control o seguimiento de las sesiones.
  • La traducción puede iniciarse tanto del lado IPv6 como del IPv4.
  • Realiza traducciones 1 a 1.
  • No permite ahorrar direcciones IPv4.
  • Posibilita y facilita el seguimiento end-to-end de las sesiones.
  • Requiere que los hosts IPv6 obtengan su dirección por configuración manual o por asignación utilizando DHCPv6.
Stateful NAT64
  • Definido en el RFC 6146.
  • Realiza un seguimiento stateful de las sesiones.
  • La traducción puede iniciarse tanto del lado IPv6 como del IPv4.
  • Soporta mapeo manual de la traducción.
  • Realiza traducciones 1:N ya que implementa overloading de direcciones.
  • Permite reducir el número de direcciones IPv4 necesarias.
  • No es posible hacer un seguimiento transparente de las sesiones end-to-end.
  • Opera independientemente del modo de asignación de las direcciones IPv6, con lo que soporta asignación estática, stateless o por DHCPv6.

Bibliografía recomendada:

18 de diciembre de 2014

Protocolo IPv6 Básico versión 2

Ya está disponible una versión actualizada del cuadernillo "Protocolo IPv6 Básico" que publicara hace ya un par de años.
Como en su versión inicial, este cuadernillo está concebido como  con el objeto de servir de soporte a un curso de iniciación al Protocolo IPv6.
Recoge de modo sintético y sencillo los principales conceptos vertidos en el desarrollo del curso y de ningún modo pretende ser un desarrollo exhaustivo del tema.
Los temas abarcados son los que he considerado como básicos y relevantes para el conocimiento de la tecnología, por lo tanto NO se incluyen algunos tópicos más avanzados tales como implementaciones de QoS, movilidad, diseño en service providers, etc.
Está compuesto de 2 secciones principales.
  • Una primera que recoge los conceptos teóricos desarrollados. 
  • Una segunda que es una Guía de Laboratorio para ejercitar algunos de los conceptos desarrollados.
Fecha de publicación: 18 de diciembre de 2014.
Autor: Oscar Gerometta
Contenidos:
  • Introducción.
  • Operación de IPv6.
  • Protocolos de enrutamiento IPv6.
  • Mecanismos de transición IPv4 a IPv6.
  • IPv4 vs. IPv6.
  • Guía de laboratorio.
Este manual es ahora de acceso libre
en la biblioteca virtual de EduBooks.
Ingrese aquí.


Novedades de la versión
  • Se ha revisado completamente el texto.
  • Se han incorporado nuevos tópicos como NAT64, DNS, DDNS, DHCPv6, etc.
  • Se han incorporado nuevos gráficos.
  • Se actualizó toda la información referente a configuración y la guía de laboratorios a IOS 15.4.
Dado que el cuadernillo ha sido concebido como herramienta didáctica de soporte para el dictado de un entrenamiento introductorio, también he desarrollado una presentación que puede servir de soporte:


Como siempre, cualquier sugerencia que puedas hacer, será muy bien venida.



13 de diciembre de 2014

Introducción a DHCPv6

El servicio dinámico de asignación de una configuración IP completa para IPv6 se realiza con una nueva versión del protocolo DHCPv4 que ya conocemos y que se denomina DHCPv6.
DHCPv6 es en términos generales semejante a su predecesor, aunque con características específicas que le son propias:
  • Utiliza transporte UDP.
    Los clientes utilizan el puerto 546.
    Los servidores utilizan el puerto 547.
  • El cliente utiliza su dirección link local como dirección de origen de la solicitud.
  • Los clientes utilizan la dirección multicast FF02::1:2 para buscar el servidor.
  • Permite implementar DHCP relay. El DHCP relay reenvía la solicitud DHCPv6 a la dirección de multicast de site local FF05::1:3
  • Para el intercambio de mensajes el servidor utiliza como dirección de origen la dirección local link.
  • Puede suministrar múltiples direcciones IPv6 a la misma interfaz.
  • Puede ser utilizado para registrar automáticamente los nombres de los dispositivos en el dominio utilizando DDNS (Dynamic Domain Name System).
  • Ha sido ratificado en el RFC 3315.
¿Por qué implementar DHCPv6 en redes IPv6?

En IPv6 se ha incorporado un servicio de asignación de direcciones automático conocido como stateless. Este mecanismo permite que, a través de un sencillo intercambio de mensajes ICMPv6, la terminal obtenga la información básica necesaria para operar dentro de la red (prefijo y gateway) directamente del router que opera como gateway, sin necesidad de la presencia de un servidor DHCPv6.
Aunque IPv6 puede resolver mecanismos de asignación automática de direcciones tales como la asignación stateless, la implementación de servicios DHCP en IPv6 tiene sentido ya que brinda mayor control sobre las asignaciones, posibilidades de registro y auditoría y una configuración IPv6 más completa (la asignación stateless no asigna servicio DNS p.e.).
El servicio provee una configuración IPv6 completa a los nodos conectados a la red para su uso temporal. 
La implementación puede coexistir con el mecanismo stateless.

Bibliografía recomendada:

7 de diciembre de 2014

Introducción a OSPFv3

Continuando con el estudio de las tecnologías vinculadas a la implementación de redes IPv6, es oportuno que demos una mirada al protocolo de enrutamiento por estado de enlace por excelencia a implementar en estas redes: OSPFv3.
  • Open Shortest Path First version 3.
  • RFC 5340.
  • Protocolo de estado de enlace.
  • Aplicable a redes corporativas de envergadura.
Conceptualmente es semejante a OSPFv2:
  • Utiliza el algoritmo de Dijkstra para selección de la mejor ruta.
  • En redes extensas, divide el dominio de enrutamiento en áreas.
  • El área 0 es el área de backbone.
  • Las áreas se conectan a través de ABRs.
  • Diferencia rutas externas de rutas internas.
  • Utiliza una métrica basada en el costo de las interfaces.
  • Utiliza los mismos tipos de paquetes (LSAs) y procedimiento de descubrimiento de vecinos que OSPFv2.
  • Soporta los mismos tipos de interfaces que OSPFv2.
Sin embargo, a pesar de estas similitudes es un protocolo totalmente independiente de OSPFv2 y corre de modo independiente.
Hay también algunas diferencias notables respecto de OSPFv2:
  • Requiere un router ID de 32 bits, que no es una dirección IP. En el caso de dispositivos solo IPv6 es obligatoria su configuración, en redes dual-stack puede asumir la dirección IPv4 de una interfaz.
  • Las adyacencias y próximos saltos se definen utilizando direcciones link-local. Como todas las interfaces utilizan el mismo prefijo link-local se almacena también la interfaz de salida.
  • En Cisco IOS se habilita por enlace e identifica las redes que están asociadas con ese enlace.
  • Requiere la activación de CEF.
Se propaga en formato de multicast:
  • FF02::5 - Todos los routers OSPF.
  • FF02::6 - Todos los routers OSPF designados.
Configuración básica de OSPFv3
Para la descripción de procedimientos de configuración y comandos he considerado Cisco IOS 15.4(2)S y IOS XE 03.12.00.S.

Router(config)#ipv6 router ospf [ID de proceso]
Router(config-router)#router-id [X.X.X.X]
Router(config-router)# exit
Router(config)#interface [interfaz]
Router(config-if)#ipv6 ospf [ID de proceso] area [ID]

Monitoreo de OSPFv3
Router#show ipv6 protocols
Router#show ipv6 ospf
Router#show ipv6 ospf [ID de proceso] [área] interface [interfaz]
Router#show ipv6 ospf [ID de proceso]
Router#clear ipv6 ospf [ID de proceso]

Bibliografía recomendada:

2 de diciembre de 2014

Tecnologías WAN v5.1

Acabo de publicar el último eje temático que compone la futura Guía de Preparación para el Examen de Certificación CCNA R&S: "Servicio IP v5.1". 
Como he aclarado en anteriores oportunidades, la Guía de Preparación no es solamente un conjunto de ejes temáticos, sino un manual metodológico completo que incluye información sobre el examen y metodología de estudio. Básicamente se compone de 3 partes:
  • Un análisis detallado de la mecánica del examen de certificación.
  • Un capítulo de metodología de estudio.
  • El desarrollo de los ejes temáticos.
Estas publicaciones que voy adelantando cubren solamente los siete ejes temáticos. Para la nueva versión de la Guía de Preparación para el Examen de Certificación he definido 7 ejes temáticos:
Esta última publicación, cubre de modo completo el séptimo eje temático que definí. 
La información detallada de este manual es la siguiente:


Fecha de publicación: 5 de diciembre de 2014
Autor: Oscar A. Gerometta
CCSI / CCNA R&S / CCDA / CCNAwir / CCNA sec. / CCBF.
Creador –en el año 2000- del primer curso de apoyo para alumnos de Cisco Networking Academy program que se preparan a rendir su examen de certificación CCNA, logrando entre sus alumnos un nivel de aprobación superior al 95%.

Texto:
Esta entrega incluye todos los elementos propios del desarrollo del eje temático Tecnologías WAN que es parte del temario del examen de certificación CCNA R&S 200-120.
Es el último eje temático de los 7 previstos para el desarrollo de la Guía de Preparación para el Examen de Certificación CCNA R&S v5.1, como una ayuda para el proceso de estudio de quienes se encuentran preparando su examen de certificación.
Está alineado al temario del examen CCNA R&S 200-120. 

Contenidos:
  • Mapa conceptual.
  • Notas previas.
  • Desarrollo temático.
  •     Terminología WAN.
  •     Tipos de conexión WAN.
  •     Líneas dedicadas (PPP, HDLC y PPoE).
  •     Frame Relay.
  • Prácticas de laboratorio.
  • Síntesis.
  • Cuestionario de repaso.
  • Respuestas del cuestionario de repaso.
Páginas: 99

Para la compra: 
Tecnologías WAN versión 5.1 se publica ÚNICAMENTE en formato e-book y ya se encuentra disponible; se puede comprar en línea ingresando aquí.
Para consultas de precios y formas de pago alternativas diríjase directamente a Ediciones EduBooks por correo electrónico escribiendo  a libros.networking@gmail.com

Características del ebook
  • El formato ebook empleado sólo funciona sobre sistemas operativos Microsoft (Windows).
  • Sólo se admite PayPal como forma de pago (consulte con la Editorial por formas de pago alternativas).
  • Dispone de 5 días a partir del momento de la compra para descargar el ebook.
  • Para poder ver la obra completa debe ingresar la clave de activación que recibirá por correo electrónico.
  • Una vez realizada la compra recibirá un correo electrónico con indicaciones detalladas para que pueda realizar la activación.
  • La clave de activación le permite activar su ebook en 1 terminal, y sólo puede ser leído desde esa terminal.
  • Ud. puede solicitar la activación de una segunda copia en un dispositivo auxiliar (p.e. su notebook), solicitándolo por correo electrónico a libros.networking@gmail.com.
  • En la terminal deberá tener instalada la aplicación Adobe Reader X versión 10.1.4.

Para quienes proyectan obtener la certificación CCENT rindiendo el examen ICND1 100-101, sugiero el Apunte Rápido CCENT v5.0 que he escrito para ese examen específicamente..

Para revisar la Guía de Preparación para el Examen de Certificación CCNA R&S versión 5.1 completa, ingrese aquí.

Como siempre, cualquier sugerencia que puedas hacer, será muy bien venida.

Enlace de referencia: