21 de febrero de 2009

Introducción a MPLS

Entre las redes de transporte, MPLS ocupa hoy un lugar de preponderancia. Es por esto de suma importancia que conozcamos al menos sintéticamente el modo en que operan estas redes.
MPLS (MultiProtocol Label Switching) es un método de reenvío de paquetes de alta performance. Se asienta en el agregado de una etiqueta al paquete IP en base a la cual se hará el reenvío de paquetes con una mínima sobrecarga por búsqueda de rutas. Definido en el RFC 3031.

Conceptos básicos
  • Mecanismo que asigna etiquetas a los paquetes, que son utilizadas para reenviar el tráfico.
  • Las etiquetas se aplican en el borde (edge) de la red. Dentro de la red el forwarding se hace en función de las etiquetas.
  • La etiqueta usualmente identifica una red de destino.
  • La implementación de MPLS requiere previamente habilitar CEF.
  • Sólo los routers de borde hacen un lookup de enrutamiento IP. Todos los routers internos de la red MPLS realizan el reenvío en base a la etiqueta.
Arquitectura de la red MPLS
La red MPLS está compuesta por 2 tipos de dispositivos:

  • LSR (Label Switch Routers)
    o P Router (Provider Router).
    Primariamente reenvía paquetes basándose en las etiquetas de MPLS. Todas sus interfaces están habilitadas para tráfico MPLS.
  • Edge LSR
    o PE Router (Provider Edge Router).
    Dispositivo que aplica o remueve la etiqueta MPLS a los paquetes.
    Solamente algunas de sus interfaces están habilitadas para MPLS, mientras que otras no.
Configuración básica de un LSR

Router(config)#ip cef
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.252
Router(config-if)#encapsulation ppp

Router(config-if)#mpls ip

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#interface fastethernet 0/0

Router(config-if)#ip address 172.16.1.1 255.255.255.0

Router(config-if)#mpls ip

Router(config-if)#mpls mtu 1504

Router(config-if)#no shutdown

Router(config-if)#exit


Configuración básica de un Edge LSR
Router(config)#ip cef
Router(config)#interface serial 0/0/0

Router(config-if)#ip address 192.168.1.2 255.255.255.252

Router(config-if)#encapsulation ppp

Router(config-if)#mpls ip

Router(config-if)#no shutdown

Router(config-if)#exit

Router(config)#interface serial 0/0
/1

Router(config-if)#ip address 192.168.1.5 255.255.255.252

Router(config-if)#encapsulation ppp

Router(config-if)#no shutdown

Router(config-if)#exit

Referencias:

Bibliografía Sugerida:
Cuadernillo MPLS Frame-Mode Básico - Oscar Gerometta.
Tenés alguna consideración o comentario para aportar en este tema....?
Perfecto!!!! agregá un comentario con el detalle.
Muchas gracias.
Oscar Gerometta

8 comentarios:

  1. No me cansaré de leer este blog. gracias.

    ResponderEliminar
  2. buen sitio para salir del paso, configuracion sin complicaciones !!!

    ResponderEliminar
  3. directo y entendible con fácil manejo del tema un 10.

    ResponderEliminar
  4. Wow!! Muy simple, entendible y concreto!! Muy bueno!! Si hubiese 11 te pondría un 11! jaja!

    ResponderEliminar
  5. Una duda, soy CCNA enfocado a seguridad pero me pidieron actualizarme a MPLS, esto es tema de CCNP? Saludos!

    ResponderEliminar
  6. En el caso de Cisco, hay un curso específico de MPLS con su examen de certificación, que son parte de la certificación CCIP (el nivel professional para service providers).

    ResponderEliminar
  7. Estimado Oscar, una consulta, se puede simular MPLS en Packet Tracer? Se necesita algo especial?

    ResponderEliminar
    Respuestas
    1. Nahuel.
      Packet Tracer no ha sido desarrollado pensando en MPLS. Si quieres trabajar MPLS tus opciones son: dispositivos reales, laboratorios de acceso remoto, o una maqueta montada en GNS3.

      Eliminar

Gracias por tu comentario.
En este blog los comentarios están moderados, por lo que su publicación está pendiente hasta la revisión del mismo.