24 de octubre de 2017

Comandos de configuración de interfaces en dispositivos Cisco - Actualización

Continuando con la revisión de las publicaciones más visitadas en estos años la siguiente es esta. Escrita también durante el primer año de este blog, es la segunda más visitada, con lo que también supongo que su información es útil para muchos y por lo tanto también decidí revisarla y actualizarla.
Este es el resultado.

Durante el proceso de configuración de dispositivos de infraestructura llega siempre el momento de realizar o modificar la configuración de una interfaz o varias interfaces. En este sentido es fundamental que tengamos en cuenta algunos comandos Cisco IOS claves, que son comunes a todas las interfaces de los dispositivos Cisco IOS.

Ante todo, todos los comandos relacionados con la configuración de las interfaces de dispositivos IOS se ejecutan en el modo configuración de interfaz:

Router#configure terminal
Router(config)#interface [tipo] [módulo/interfaz.subinterfaz]

Un ejemplo:
Router(config)#interface GigabitEthernet 0/0

De esta forma se ingresa al modo de configuración de la interfaz tanto de routers como switches o firewalls Cisco.
Es necesario indicar la interfaz que se desea configurar o crear, según sea el caso.

Alternativamente, cuando debemos realizar la configuración de un grupo de interfaces de igual tipo y con los mismos parámetros (algo habitual en el caso de los switches) se puede utilizar el comando interface range:

Switch(config)#interface range FastEthernet 0/1 - 10
Switch(config-if-range)#_

Una vez en el modo configuración de interfaz se puede consultar el listado de comandos disponibles utilizando el comando de ayuda habitual: ? debemos tener presente que la lista de comandos que se genera varía de acuerdo al tipo de interfaz, la plataforma y la versión de IOS de que se trate.
En esta lista de comandos, algunos de los básicos son:


Router(config-if)#no shutdown
Las interfaces de los routers Cisco IOS tienen sus interfaces inactivas por defecto por lo que requieren ser activadas por configuración para que sean operativas.
Los switches Cisco Catalyst, en cambio, tienen todas sus bocas activas por defecto, motivo por el cual se sugiere que aquellas que no sean utilizadas sean desactivadas por configuración.
Para que una interfaz sea activa debe encontrarse en estado up/up, para lo cual en el caso de los routers es necesario que los puertos sean habilitados manualmente por el administrador utilizando el comando:

Router(config-if)#no shutdown

Al hacer copias de respaldo de los archivos de configuración es preciso recordar que este comando no se guarda en el archivo de configuración por lo que es conveniente editar esos archivos para agregar este comando en cada interfaz para facilitar que los puertos sean inmediatamente operativos cuando se haga una restauración de esa configuración.


Router(config-if)#ip address x.x.x.x x.x.x.x
Este comando que permite asignar una dirección IPv4 a una interfaz. El comando requiere que se ingrese tanto una dirección IPv4 como una máscara de subred, de lo contrario devolverá un mensaje de comando incompleto.

Router(config-if)#ip address 172.16.15.1 255.255.255.0

Una variante posible es activar el cliente DHCP de IOS en la interfaz de modo que obtenga una dirección IPv4 utilizando el protocolo DHCP:

Router(config-if)#ip address dhcp


Router(config-if)#ipv6 enable
Cuando se trata de implementar redes IPv6 este comando activa el protocolo enrutado en la interfaz.
Consecuencia inmediata de la activación del protocolo es la generación automática en la misma interfaz de la dirección IPv6 link-local (FE80::/10) correspondiente, utilizando EUI-64 para derivar la porción de nodo.
Cuando se ha de configurar una dirección IPv6 unicast global o unique-local este comando es opcional ya que al configurar la dirección se activa automáticamente el protocolo en la interfaz.


Router(config-if)#ipv6 address xxxx::/XX
Comando que permite asignar una dirección IPv6 a una interfaz.
Con diferentes variantes permite definir una dirección completamente estática o asignar solamente un prefijo de red y requerir que el ID de nodo se asigne automáticamente utilizando EUI-64. Requiere la identificación de la longitud del prefijo que identifica el segmento de red al que pertenece la interfaz.

Router(config-if)#ipv6 address 2001:db8:1:1::1/64
Router(config-if)#ipv6 address 2001:db8:1::/64 eui-64
Router(config-if)#ipv6 address FE80::1 link-local
En este caso también es posible activar el cliente dhcpv6 a la asignación de IPv6 utilizando la autoconfiguración stateless propia del protocolo.

Router(config-if)#ipv6 address autoconfig
Router(config-if)#ipv6 address dhcp



Router(config-if)#description
Si bien la incorporación de una descripción a la interfaz es un feature opcional es un recurso importante a tener en cuenta para facilitar la identificación de interfaces y las tareas de diagnóstico y resolución de fallos. La inclusión de una descripción clara y precisa ahorra tiempo y simplifica tareas futuras.
La forma de agregar una descripción en la configuración es la siguiente:
Router(config-if)#descriptioin LAN de ventas
También se puede agregar información de referencia tal como:

Router(config-if)#description enlace Eth con Acme soporte 0800-444-4444

Este tipo de anotaciones o referencias es de utilidad para facilitar tareas de resolución de problemas.


Router(config-if)#bandwitdh
Este es también un comando opcional pero necesario ya que es utilizado por diferentes algoritmos de cálculo que utiliza el sistema operativo. Entre ellos el algoritmo de aquellos protocolos de enrutamiento que utilizan el ancho de banda para sus cálculos de métrica, los algoritmos de asignación de recursos (QoS), los cálculos de nivel de utilización de las interfaces.
Es importante tener en cuenta que este comando declara el ancho de banda en Kbits. Los valores por defecto son diferentes en interfaces LAN o WAN.
En interfaces Ethernet se toma como valor BW la velocidad a la que ha negociado la interfaz cuando está habilitada la autonegociación, o la velocidad definida en el puerto cuando se ha optado por una configuración estática. 
En interfaces seriales el valor por defecto es el correspondiente a una interfaz E1: 1544 Kb.

Router(config-if)#bandwidth 1024

El valor efectivamente en uso en cada interfaz puede ser consultado utilizando el comando show interfaces.


Router(config-if)#duplex auto
Router(config-if)#speed auto
Se trata de comandos relacionados con las interfaces de la familia Ethernet de routers y switches.
Estos son dos comandos de suma importancia, ya que los valores de operación de ambos extremos de un enlace deben coincidir y en definitiva determinan la operación y performance de un segmento de red.
Por ejemplo, para configurar una interface como Fastethernet en modo full dúplex:

Router(config-if)#speed 100
Router(config-if)#duplex full

Los valores de velocidad (speed) posibles dependen del hardware del dispositivo.  En general, por defecto, las interfaces están en modo autosensitivo:

Router(config-if)#speed auto
Router(config-if)#duplex auto


Switch(config-if)#switchport xxxxx
Se trata de un comando propio de switches (no en routers), que permite colocar definir características de operación de puertos que operan en capa 2. De este comando dependen diferentes prestaciones: enlace troncal o de acceso, port-security, etc.
Por ejemplo, para configurar una interfaz en modo acceso o troncal:

Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 14

Switch(config-if)#switchport mode trunk

También se utiliza este comando en switches capa 3 para definir un puerto específico como puerto capa 2 o capa 3. Por ejemplo, para que un puerto comience a operar como interfaz ruteada:

Switch(config-if)#no switchport




Las abreviaturas y siglas utilizadas en este post puede encontrarlas desarrolladas en
que está disponible en la Librería en Línea de EduBooks.


2 comentarios:

  1. Estimado Oscar,

    Podrias ayudarme con estos conceptos, especialmente con el punto 4.3.d, con respecto a la conifguracion de TFTP en router con configuracion DHCP.

    Muchas Gracias desde Ya!

    Configure and verify DHCP on a router (excluding static reservations)

    4.3.a Server
    4.3.b Relay
    4.3.c Client
    4.3.d TFTP, DNS, and gateway options

    ResponderEliminar
    Respuestas
    1. Miguel.
      Lo que estás buscando es un desarrollo completo de la operación del protocolo DHCPv4, lo cual excede lo que se puede presentar en un comentario de un post.
      Los puntos a, b y c están referidos a las 3 funciones básicas de dispositivos que implementan DHCP: servidores DHCP, clientes DHCP (como el de tu PC) y relays DHCP que permiten alcanzar servidores DHCP que están alojados en otro segmento de red.
      El punto D se refiere a la utilización de los diferentes campos de la respuesta DHCP (llamados "options"), algunos de ellos para información de configuración básica como IP, máscara de subred, servidores DNS y gateway; otros a información opcional como puede ser la dirección IP de un servidor TFTP o de un controlador inalámbrico.
      Creo que este documento puede servirte como introducción al tema, pero hay mucha tela para cortar sobre esto:
      https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr_dhcp/configuration/15-mt/dhcp-15-mt-book/dhcp-overview.html

      Eliminar

Gracias por tu comentario.
En este blog los comentarios están moderados, por lo que su publicación está pendiente hasta la revisión del mismo.