11 de agosto de 2006

Comandos de configuración de interfaces en dispositivos Cisco

Más allá de la experiencia o conocimientos que cada uno de nosotros tenga en la administración y configuración de dispositivos Cisco, al momento de tener que realizar o modificar la configuración de una interfaz, es importante que tengamos en cuanta algunos comandos Cisco IOS claves, que son comunes a todas las interfaces de los dispositivos Cisco.


Ante todo, todos los comandos relacionados con la configuración de algún aspecto de las interfaces, se ejecutan en el modo configuración de interfaz:
Router#configure terminal
Router(config)#interface [tipo] [módulo/interfaz.subinterfaz]
Router(config)#interface fastethernet 0/0.1

De este modo se ingresa al modo de configuración de la interfaz tanto de routers como switches Cisco.
Se requiere especificar la interfaz que se desea configurar.

Alternativamente, cuando es necesario realizar la configuración de un grupo de interfaces con los mismos parámetros (por ejemplo en el caso de los switches), se puede utilizar el comando interface range:
Switch(config)#interface range fastethernet 0/1 - 10
Switch(config-if-range)#_

Una vez en el modo configuración de interfaz se puede consultar el listado de comandos disponibles utilizando el comando de ayuda habitual: ? Tenga en cuenta que esta lista de comandos varía de acuerdo al tipo de interfaz de que se trate y el package de Cisco IOS implementado.
En esta lista de comandos, los básicos son:
no shutdown
Los routers Cisco presentan todos sus puertos en estado shutdown por defecto.
Los routers Linksys en cambio, tienen todos sus puertos en estado no shutdown por defecto.
Los switches Cisco también tienen todas sus bocas en estado no shutdown por defecto.

Para ser operativos, los puertos que están "bajos" deben ser habilitados manualmente por el administrador utilizando el comando:
Router(config-if)#no shutdown
Si hace copias de respaldo de sus configuraciones en archivos de texto, tenga presente que deberá editar esos archivos para agregar este comando en cada interfaz, ya que no aparece en el archivo de configuración.
ip address
Este es el comando que permite asignar una dirección IP a un puerto. Este comando requiere que se ingrese tanto la dirección IP como la máscara de subred:

Router(config-if)#ip address 172.16.15.1 255.255.255.0
Una alternativa posible, es configurar el puerto para que haga una solicitud IP utilizando el protocolo DHCP:
Router(config-if)#ip address dhcp
descriptionSi bien la incorporación de una descripción a la interfaz es un feature opcional, constituye un recurso importante a tener en cuenta para facilitar la identificación de interfaces y las tareas de diagnóstico y resolución de fallos. La inclusión de una descripción clara ahorra tiempo y simplifica tareas futuras.
La forma de agregar una descripción en la configuración es la siguiente:
Router(config-if)#descriptioin LAN de ventas
También se puede agregar información de referencia tal como:
Router(config-if)#description enlace E1 contratado con Acme soporte 0800-444-4444
Este tipo de anotaciones es de importancia para facilitar tareas de resolución de problemas.
bandwitch
Este es también un comando opcional, ya que solamente es utilizado por aquellos protocolos de enrutamiento que utilizan el ancho de banda como parámetro para sus cálculos de métrica.

Es importante tener presente que este comando declara el ancho de banda en Kbits. Las interfaces LAN no requieren la configuración de este parámetro ya que asumen el valor correspondiente al tipo de interfaz. Las interfaces seriales tienen asignado por defecto el valor correspondiente a una interfaz E1: 1544 Kb.
Router(config-if)#bandwidth 1024
Sobre este comando en particular se puede consultar este artículo en este mismo weblog.
ip access-group
Si se desean aplicar listas de acceso para filtrar tráfico entrante o saliente del dispositivo a través de una interfaz se debe utilizar este comando especificando la lista de acceso que se desea aplicar, y en qué sentido del tráfico debe ser aplicada:

Router(config-if)#ip access-group 120 out
duplex y speedSe trata de comandos relacionados con las interfaces de la familia Ethernet de routers y switches.
Estos son dos comandos de suma importancia, ya que los valores de configuración de ambos extremos de un enlace deben coincidir. De no ser así, el enlace no será operativo.
Para configurar una interface como fastethernet en modo full dúplex:
Router(config-if)#speed 100
Router(config-if)#duplex full

El valor de speed posible, depende del hardware del dispositivo. No están disponibles en dispositivos equipados con interfaces Ethernet. En general, por defecto, las interfaces están en modo autosensitivo:
Router(config-if)#speed auto
Router(config-if)#duplex auto

switchport
Este comando funciona solamente en switches, no en routers. Permite colocar una boca del switch en modo troncal o modo acceso, ubicarla en una determinada VLAN o introducir el conjunto de comandos de seguridad del puerto.

Por ejemplo, para configurar una interfaz en modo acceso a fin de conectar en ella un dispositivo:
Switch(config-if)#switchport mode access
Para incorporar un interfaz a una VLAN:
Switch(config-if)#switchport access vlan 4
Bibliografía sugerida:
Principios Básicos de Networking para redes Cisco IOS - Oscar Gerometta
Guía de Preparación para el Examen de Certificación CCNA R&S 200-120 versión 5.1 - Oscar Gerometta
¿Tenés alguna información adicional para aportar en este tema?
Perfecto!!!! Todo aporte es bienvenido. Agregá un comentario con el detalle.
Muchas gracias.
Oscar Antonio Gerometta

27 comentarios:

  1. me yama la atencion tu articulo y esta muy bien y espero publiques mas ya que estan muy razonables y explicados a comparcion de la curicula de cisco que aveses pierde a los alumnos entre tanta teoria explicada como si se refiriera a unos expertos o cuandomenos personas enfocadas a estos temas
    brambila_62@hotmail.com
    gustavo brambila

    ResponderEliminar
  2. me gusto tu articulo y pienso que es mejor que leer la grancurricula de cisco que aveses pierde a los alumnos entre tanta teoria sobretodo con los comandos que tratan de explicar a fondo los revuelven mas de lo que estan

    ResponderEliminar
  3. cual seria un comando para monitorear e trafico dentro el router, iniciando una sesion desde telnet ?

    de antemano gracias

    ResponderEliminar
  4. Hola, si alguien puede ayudarme se lo agradecere mucho, estoy intentando configurar el router para que el puerto WAN acepte DHCP y quiero configurar uno de los puertos fastethernet con alguna IP fija pero no puedo, me muestra un mensaje que la verdad no entiendo, no tengo muchos conocimientos de cisco, apenas voy empezando. Para configurar el DHCP hice lo siguiente

    Router>enable
    Router#configure terminal
    Router(config)#interface fastEthernet 4
    Router(config-if)#ip address dhcp
    Router(config-if)#no shutdown
    Router(config-if)#exit
    Router(config)#

    conecte el cable de red al puerto WAN y me di cuenta que si se le asigna IP y esta arriba, con el show interface

    pero cuando quise asignarle IP fija al puerto 0 me muestra lo siguiente:

    IP addresses may not be configured on L2 links FastEthernet0.

    no entiendo el porque, si alguien pudiera explicarme porque y como podria hacer para solucionarlo, gracias y saludos.

    ResponderEliminar
    Respuestas
    1. Estimado.
      Por lo que dices supongo que estás intentando configurar un Cisco 800.
      Si es así, los puertos 0 a 4 son en realidad puertos de un switch integrado, y por lo tanto no soportan configuración IP. La dirección IP en ese caso se configura en la interfaz vlan 1.

      Eliminar
    2. Estimado Oscar Gerometta:
      En caso de que le asigne una vlan a uno de los 4 puertos, la direccion ip debe ser configurada en la inerfaz vlan (numero de vlan)?

      ejemplo si al puerto 4 le asigne la vlan 20, deberia quedar:
      interfaz vlan 20
      IP addres (ip y mascara)

      saludos

      Eliminar
    3. Siguiendo con la suposición de que se trata de un Cisco 800, los puertos FastEth 0 a 3 son parte de un switch LAN, el puerto FastEth 4 es el puerto WAN.
      El puerto 4 puede recibir IP directamente, pues es una interfaz capa 3.
      Los puertos 0 a 3 no pueden recibir IP ya que son puertos capa 2.
      Esos puertos pueden ser asignados a una VLAN, y después crear una SVI para esa VLAN, y allí asignar la IP.

      Eliminar
  5. Hola a todos, mi duda es la siguiente. Me piden conectarme remotamente desde un PC al router R1 para levantar una interface de R1 que han conectado a un switch, pero no saben decirme a cual interface Fast Ethernet de R1 han conectado el cable, ¿hay algun comando de la CLI para saber que interface tiene fisicamente conectado el cable? Si no hay ningun comando ¿como sabría con que interface trabajar? He estado haciendo pruebas con el simulador gns3, y no encuentro la manera de identificar cual es la interface con la que trabajar. En mi simulación f1/0 de R1 está sin cablear y f1/1 es la que va al swicht, y esta es la salida de uno de los comandos show:

    R1#show ip int f1/0
    FastEthernet1/0 is up, line protocol is up
    Internet protocol processing disabled
    R1#show ip int f1/1
    FastEthernet1/1 is up, line protocol is up
    Internet protocol processing disabled

    He estado comparando las salidas del show controllers y show interfaces y no hay diferencia entre los 2 puertos.

    Gracias

    ResponderEliminar
    Respuestas
    1. Ya he visto esta consulta en otros foros.
      El comando de CLI en un router para reconocer la conexión de capa física es show controllers. En un puerto en el que no hay cable conectado te reportará "no cable".
      Claro que esto servirá suponiendo que el dispositivo en el otro extremo del cable se encuentre encendido y el puerto se encuentre habilitado administrativamente (no shutdown). Si el puerto está deshabilitado, deberás habilitarlo antes de intentar el reconocimiento.
      Pero creo que esto ya te lo han explicado.
      Tu simulación no sirve, porque el resultado del show te está mostando un resultado incongruente; si mantuviste la configuración de los puertos por defecto y el el f1/0 no está cableado nunca podría reportar up/up (la capa de enlace no puede levantar si la capa física no está operativa) a menos que hayas deshabilitado el reconocimiento de loopback por configuración.

      Eliminar
  6. Este comentario ha sido eliminado por el autor.

    ResponderEliminar
  7. PAEA QUE SIRVE EL COMANDO DUPLEX FULL

    ResponderEliminar
    Respuestas
    1. Como se sugiere en el post, fuerza la interfaz a operar en modo full dúplex.

      Eliminar
  8. Hola, tengo una pregunta, tengo un cisco 2960 operando en produccion pero requiero cambiar unos valores de speed y duplex en algunas interfaces y la pregunta es si estos cambios los puedo realizar directamente con el cisco funcionando con trafico o si se requiere dar de baja algo para realizar los cambios. De antemano gracias.

    ResponderEliminar
    Respuestas
    1. Los cambios pueden realizarse en un dispositivo en producción y serán aplicados de modo inmediato luego de su ingreso.
      Sin embargo, hay que tener presente que al cambiar la configuración de las interfaces es posible que se provoquen cortes en las sesiones que atraviesan esas interfaces, sobre todo cuando puede haber diferencias de configuración con los dispositivos terminales conectados.
      Hacer cambios con el dispositivo en producción requiere conocimiento, planificación,y un plan de contingencia adecuado.

      Eliminar
  9. Hola Oscar, como siempre excelentes artículos.
    tengo una pregunta estoy configurando un router cisco 2911 lo básico(nombre, contraseña) y mando a guardar "copy running-config startup-config" aparentemente se guarda. apago el router lo vuelvo a encender y se reinicia y se borra todo lo que configure...
    por favor una sugerencia que podría hacer..

    ResponderEliminar
    Respuestas
    1. Es posible que hayan ejecutado un procedimiento de recuperación de claves y (aunque en realidad la configuración se guarda) el registro de configuración esté indicando que no se lea la configuración guardada en la memoria flash.
      Verifica el registro de configuración utilizando el comando show version. El valor regular de operación debiera ser ox2102.

      Eliminar
    2. Gracias Oscar, lo hice y funciono perfecto..
      Saludos Estefania Salinas ,Loja-Ecuador

      Eliminar
  10. Cual es la diferencia en configurar solo con el comando switchport mode access y no poner el comando
    switchport access vlan 4 por ejemplo, en ese caso por ¿Cuál vlan se enruta?

    Gracias su ayuda

    ResponderEliminar
    Respuestas
    1. Ángel.
      Con el comando switchport mode access lo que haces es que el puerto que por defecto se encuentra en modo dinámico quede fijo en modo acceso. Como la VLAN de acceso por defecto es la VLAN 1, si no especificas la VLAN con el segundo comando entonces ese puerto quedará como puerto de acceso de la VLAN 1.
      No se trata de enrutar una VLAN (eso se haría en una interfaz VLAN, por ejemplo, sino de asociar un puerto a una VLAN.

      Eliminar
  11. orale super genial me sacate de algunas dudas. sobre el comando interface range. gracias bun aporte

    ResponderEliminar
  12. Guau! Muchas gracias, ya con esto termine de configurar mi router. Estan mas que claros tus tutoriales. Gracias amigo

    ResponderEliminar
  13. Oscar tengo dudas con el comando switchport mode acces, lo que entiendo es que cuando manejo vlans ¿ con este comando puedo optimizar el puerto? para que no vea la difusión de todas las vlans.

    ResponderEliminar
    Respuestas
    1. El comando switchport mode access no es un comando para "optimización" del puerto, sino que lo que hace es colocar el puerto (que por defecto se encuentra en modo dinámico) en modo acceso. Si es una práctica de seguridad para evitar que eventualmente un atacante tenga la posibilidad de forzar el puerto a modo troncal.
      Respecto del tráfico de broadcast, no hay tráfico de broadcast entre VLANs.

      Eliminar
  14. Oscar, tengo una interfaz "caida" esta en modo down, cual es el comando para levantar esta interfaz?

    ResponderEliminar
    Respuestas
    1. Si el estado de la interfaz es "administratively down" lo que indica es que la interfaz no está habilitada y se requiere el comando "no shutdown".
      Si no es así, y el comando es simplemente "down" hay que revisar la causa.

      Eliminar

Gracias por tu comentario.
En este blog los comentarios están moderados, por lo que su publicación está pendiente hasta la revisión del mismo.